2013 m. spalio 23 d., trečiadienis

Mikrotik + TEO GALA TV

Kaip paleisti TEO GALA TV per Mikrotik maršrutizatorių? Paprasta. Pats naudoju Mikrotik RB2011UAS-2HnD-IN su trimis GALA priedėliais. Šį manual'ą rašiau iš atminties, taigi gali pasitaikyti klaidelių, tačiau bendras principas turi būti aiškus. Stengiausi, kad instrukcija būtų universali visiems Mikrotik modeliams ir RouterOS versijoms. Aprašyta konfigūracija: pirmas router'io port'as skirtas WAN, penktas ir ketvirtas - GALA priedėliams. Firewall/NAT nustatymai standartiniai.

GALA TV srautas nuo bendro Jus pasiekiančio interneto srauto atskiriamas virtualiu LAN'u su ID 6, taigi ant WAN interfeiso (mano atveju ether1, tačiau priklausomai nuo Mikrotik modelio jis gali vadintis ether1-gateway, ether1-wan ir pnš.) sukūriam vlan interfeisą su vlan-id=6, pavadinam jį, tarkim, vlan-gala:
/interface vlan add name=vlan-gala vlan-id=6 interface=ether1
Sukūriam atskirą bridge'ą GALA televizijai: 
/interface bridge add name="GalaTv" disabled=no
Priskiriam interfeisą vlan-gala bridge'ui GalaTv:
/interface bridge port add interface=vlan-gala bridge=GalaTv
Pašalinam iš bridge'o* ir pridedam į GalaTv bridge'ą ethernet interfeisą į kurį jungiasi GALA TV priedėlis (mano atveju ether5**):
/interface ethernet set ether5 master-port=none
/interface bridge port remove [find interface=ether5]
/interface bridge port add interface=ether5 bridge=GalaTv
Kiekvienam papildomam GALA TV priedėliui pakanka nurodyti master-port=ether5 ant atitinkamo ethernet interfeiso. Mano atveju jungsiu antrą GALA TV priedėlį į ether4**:
/interface ethernet set ether4 master-port=ether5
Perkraunam GALA TV priedėlį ir viskas turi veikti.
* Pašalinti interfeisą iš bridge'o reikia todėl, kad jie gali būti LAN'o bridge.
** Nepamirštam, kad interfeisų pavadimai gali skirtis priklausomai nuo Mikrotik'o modelio. 

46 komentarai:

  1. Gaunu tokia zinute, kai noriu sukonfiguruoti ethernet 4.
    only one master port in switch group allowed

    AtsakytiPanaikinti
  2. Autorius pašalino šį komentarą.

    AtsakytiPanaikinti
    Atsakymai
    1. Reiškia tavo LAN switch'as naudoja master-port. Nuimk ether4 LAN'o master-port ir pridėk į GalaTv bridge'ą:

      /interface ethernet set ether4 master-port=none
      /interface bridge port remove [find interface=ether4]
      /interface bridge port add interface=ether4 bridge=GalaTv

      Panaikinti
  3. Sveiki,

    Gal galėsit patarti? Turiu MikroTik RB951G-2HnD. Susikonfigūravau pagal jūsų nurodymus, bet priedėlis sako: Could not get an IP address. Kas gali būti negerai?

    AtsakytiPanaikinti
  4. Internetas kompiuteryje veikia tvarkingai? Bandei normaliai perkrauti priedėlį (atjungti/prijungti maitinima)? Galbūt Mikrotike reikia įmesti multicast package, bet nesu dėl to tikras. Jeigu ką:

    /interface export
    /ip export

    Parašyk man output'ą. Tik prieš tai ištrink wifi informaciją, ten rodomas tavo wifi slaptažodis.

    AtsakytiPanaikinti
    Atsakymai
    1. Šiaip internetas veikia puikiai. Bandžiau prijungti prie televizijos porto kompiuterį. Kaip suprantu, turėtų gauti kažkokį adresą? Bet jo negauna. Gauna Connection-specific DNS Suffix:
      Description: Realtek PCIe GBE Family Controller
      Physical Address: ‎B4-B5-2F-8C-40-AD
      DHCP Enabled: Yes
      Autoconfiguration IPv4 Address: 169.254.76.173
      IPv4 Subnet Mask: 255.255.0.0
      IPv4 Default Gateway:
      IPv4 DNS Server:
      IPv4 WINS Server:
      NetBIOS over Tcpip Enabled: Yes
      Link-local IPv6 Address: fe80::f170:f4e3:a23c:4cad%39
      IPv6 Default Gateway:
      IPv6 DNS Servers: fec0:0:0:ffff::1%1, fec0:0:0:ffff::2%1, fec0:0:0:ffff::3%1

      Panaikinti
  5. Neleidžia čia paste'int. Per daug simbolių. https://www.dropbox.com/s/y64kbxpkg34x5gs/mikrotik_gala.txt

    AtsakytiPanaikinti
  6. Kokį traffiką tau rodo vlan6 rx, GalaTV rx ir ether5 tx?

    Vaje kiek taisyklių, pas mane 5 kartus mažiau, gali bandyti uždėti firewall'e chain=forward vietoj input taisyklėms su connection-state=established ir connection-state=related. Arba acceptinti visus UDP paketus (tik pratestavimui). Bus aišku ar dėl firewall problema.

    Turiu 951, galėsiu pratestuoti su tavo konfigūracija, tik negaliu pažadėti kada tai padarysiu.

    AtsakytiPanaikinti
    Atsakymai
    1. vlan6 rx, GalaTV rx ir ether5tx - 0bps. Kartas nuo karto pasidaro kokie 4-5kbps sekundei kokiai. /ip firewall filter add chain=input protocol=udp action=accept comment="UDP" disabled=no šitaip tinka?

      Panaikinti
  7. Manau tinka, bet labai abejoju ar kažkas pasikeis. Susimesk multicast package į RouterOS. Vakare pažiūrėsiu ant savo RB951, turėtų viskas paaiškėti.

    AtsakytiPanaikinti
    Atsakymai
    1. Va dar ką atradau prie Firewall --> Connections
      protocol=igmp src-address=10.30.6.3 dst-address=224.0.0.1
      reply-src-address=224.0.0.1 reply-dst-address=10.30.6.3 timeout=8m8s
      p2p=none
      Kaip suprantu, čia televizijos ip, bet kažkodėl negali susijungt...

      Panaikinti
    2. Pabandžiau namie su RB951. Viskas veikia, firewall nustatymų neliečiau. Duodu 99%, kad pas tave nėra multicast paketo.

      Panaikinti
    3. Vakar susimečiau, bet kažkodėl neveikia... Gal ne taip susimečiau

      Panaikinti
    4. Užveikė! :) Pasirodo sumetus multicast'ą, reikėjo ištrint ir iš naujo sukurt VLAN ir bridge'us. Ačiū už patarimus! :)

      Panaikinti
    5. Sveiki,

      Gal galite parašyti kaip ta multikast'ą susikurti ? būčiau labai dekingas.

      Panaikinti
    6. Reikia, kad būtų įdiegtas ir įjungtas multicast straming'o paketas. Jį galima atsisiųsti kartu su RouterOS ir kitų paketų atnaujinimu iš https://mikrotik.com/download

      Jei paketas jau įdiegtas, jį įjungti galima su terminalo komanda "/system package enable multicast" arba per interfeisą System>Packages

      Panaikinti
  8. Aciu, susidejau, Gala rodo.
    tik beda ta kad vaizdas tv siek tiek stringa. cia pas mane viena taip?
    Resources'ai load'o nerodo, prie interface'u Rx'a rodo 4.5Mbps Rx tiek ties vlan'u, tiek brinde'u. Kokios gali buti bedos?

    AtsakytiPanaikinti
    Atsakymai
    1. Man niekas nestabdo. Strigineja vaizdas ir cirskia garsas tik kai siunciuosi per torrentus. Kiti variantai: wlan portas Galos bridge arba ribotas tinklo pralaidumas. LAN pralaiduma galima tikrinti su btest programele, kuria galima atsisiusti is mikrotik.com. WAN pralaiduma tikrinu per speed.zebra.lt

      Panaikinti
  9. Autorius pašalino šį komentarą.

    AtsakytiPanaikinti
  10. Postui jau beveik trys metai. Ar vis dar veikia? Nesugalvojo TEO pakeisti pvz. VLAN ID ar dar kokių nors nesąmonių?

    AtsakytiPanaikinti
    Atsakymai
    1. Vlan ID visada egzistavo, jis yr statinis - 6.
      O daugiau jokių paikitimų, apart to, kad uždėjo DRM apsaugą ant viasat ir tv1000 kanalų

      Panaikinti
  11. Sveiki, o gal pavyko pasidaryti, kad gala TV veiktų per lan ir wifi kompiuteriuose?

    AtsakytiPanaikinti
  12. Sveiki, ar dar gyvu yra? metai jau 2017 o problemos kaip ir 2013 :)) gal galite padeti su gala konfigu ne mikrotik routeryje?
    Konkreciau: EdgeRouter Lite-3 irenginukas pagal portu skaiciu puikiai tinka galatv+internetas konfigui, bent jau as taip galvoju, taciau susitvarkyti nepavyksta! ziniu trukumas. brukstelkit prasau jeigu kas galetumet pagelbet? ne uz aciu!

    AtsakytiPanaikinti
    Atsakymai
    1. Teorija paprasta. Reikia atskirti VLAN ID 6 ir paduoti jį routerio portui į kurį jungiasi TV priedėlis.

      IP telefonui turėtų veikti su VLAN 5, bet šito pats nebandžiau.

      Žiūrint tavo manualą tai atrodo reikia tiesiog sukurti VLAN su ID=6 ir parent interface=tv priedelio port'as.

      Panaikinti
    2. Labai aciu uz zaibiska reakcija:) taip teoriskai ir man atrodo viskas paprasta, bet praktiskai nesugebu:(

      zodziu mano norai: eth0 WAN
      eth1 LAN (internetas i kompus ir wifi AP)
      eth2 TEOTV
      Butu zinoma faina kad TV dar matytusi ir per kompus LAN'e bet prioritetas bent kad veiktu priedelis.

      o pavyksta tik taip eth0 WAN
      eth1 LAN internetas veikia
      sukuriu vlan'a id 6 eth0.6 interfeisas gauna adresa is TEO.
      eth2 nezinau ka toliau daryti :)
      p.s. kai vlan'as gauna teotv adresa. internetas LANE nebeveikia. :(

      kaip suprantu cia jau klausimas su srautais... bet cia ir beda. mano zinios ties tuo ir baigiasi..

      Panaikinti
    3. kaip suprantu kazko konkretaus cia nebegausiu..? ;/

      Panaikinti
    4. Nelabai kuom galiu pagelbėti. vlan'as adreso neturi gauti, adresą turi gauti tv priedėlis (arba kompiuteris, jeigu jį pajungsi į tą portą). Tavo tikslas prijungti tv priedėlį tiesiogiai prie Telia iptv tinklo be jokių tarpinių routinimų. Aš tam tikslui naudoju network bridge. Nežinau koks funkcionalumas pas tave yra, gal galima daryti per bridge, gal per virtualų switch.

      Panaikinti
    5. Sukuri VLAN6 eth1 (pas mane WAN portas), tada sukuri VLAN6 portui, kuriame jungsi IP TV priedeli (pvz eth 2) ir abu VLAN6 sutiltini (bridge 1.6 ir 2.6). Pirma jungi WAN laida, tada IPTV priedeli, lauki, kol pasigaus 10.xx.xx.xx IP adresa, patikrini ar rodo TV ir tik tuomet prijungi LAN laida i savo vietinio tinklo porta.
      Sitaip turetu veikti, idomiau buti paleisti IPTV srauta per viena porta kartu su LAN i switcha ir is ten pasigauti IP TV srauta. Sito dar neisbandziau.

      Panaikinti
  13. klausimėlis - o kaip padaryti, kad ant to pačio porto suktusi ir gala ir įprastas tinklas. pvz. kai iki TV ateina tik vienas kabelis ir reikia papildomai pajungti NAS ar panašiai (kabelio dalinimas ne sprendimasi :))

    AtsakytiPanaikinti
  14. Sveiki,

    gal kam teko Mikrotik RB962UiGS-5HacT2HnT su GPON-ONU SFP jungti prie Telia (Teo) tinklo?

    AtsakytiPanaikinti
  15. Gal kam pavyko ant mikrotik isspresti problema - kai paleidi torrentus pilnu pajegumu pradeda strigineti IPTV, mikrotike iptv sukonfiguoruotas per bridge. AntTelia Technicolor eina idealiai, torrent siuntimo greitis nepamazintas.

    AtsakytiPanaikinti
    Atsakymai
    1. Tiesa fasttrack irgi napadeda. Per Queue Tree sumazinus srauta ne iptv situacija pasitaiso, tacia uturi savo minusa, kad tenka 20bps atiduoti IPTV nors jos ir neziuri.

      Panaikinti
  16. Straipsnio autorius naudoja "virtual interface" vlan atskyrimui, ir "bridge" interfeisu sujungimui su juo. Visa tai eina per mikrotiko cpu, ir esant didesniam apkrovimui pradeda strigti. Geresnis sprendimas butu naudoti mikrotike esancio switcho procesoriu atskirti vlan srauta.

    Cia pas mane i eth1 porta ateina WAN, o eth2 iseina iptv.

    /interface ethernet switch port
    set 0 vlan-header=always-strip vlan-mode=fallback
    set 1 default-vlan-id=6 vlan-header=always-strip vlan-mode=secure

    /interface ethernet
    set [ find default-name=ether2 ] comment="VLAN 6" master-port=ether1

    AtsakytiPanaikinti
    Atsakymai
    1. Naujuose sw nebėra "master port", gal žinote kaip sukonfiguruot be "master port"?

      Panaikinti
    2. zodziu gavosi taip"

      /interface ethernet switch port
      set 0 vlan-header=always-strip vlan-mode=fallback
      set 1 default-vlan-id=6 vlan-header=always-strip vlan-mode=secure

      /interface ethernet switch vlan
      add independent-learning=no ports=ether1-WAN,ether2-local switch=switch1 \
      vlan-id=6

      Panaikinti
  17. Sveiki
    Patarkit kaip per porta sukonfiguruota IPTV padaryti kad pajungus kompiuteri internetas irgi veiktu.
    Aciu

    AtsakytiPanaikinti
  18. #Hardware switching palaikymas:
    # post-v6.41 bridge hw-offload configuration

    #eth10 - wan portas
    #eth8 - priedelio portas


    /interface bridge
    add name=bridge-wan igmp-snooping=no protocol-mode=none

    /interface bridge port
    add bridge=bridge-wan interface=ether10 hw=yes
    add bridge=bridge-wan interface=ether8 hw=yes

    #mano atveju eth10 ir eth8 priklauso switch2
    /interface ethernet switch vlan
    add ports=ether10,switch2-cpu switch=switch2 vlan-id=0
    add ports=ether10,ether8 switch=switch2 vlan-id=6

    /interface ethernet switch port
    set ether10 vlan-mode=secure vlan-header=leave-as-is
    set ether8 vlan-mode=secure vlan-header=always-strip default-vlan-id=6

    #nueinam web interfeise /IP/Firewall/Nat ir paraudonintas taisykles pakeiciam interface -> bridge-wan
    #mano atveju paraudonintu buvo tik NAT tabe

    AtsakytiPanaikinti
    Atsakymai
    1. pamirsau paminet, kad riekes panaikint pries tai aprasyta konfiga ir pakeisti DHCP Client interface i bridge-wan

      Panaikinti
  19. Sveiki, ar kas nors bandėt paleisti TV srautą per wirfi? Esmė tame, kad noriu pajungti priedėlį kur nėra galimybės atsivesti kabelio. Tarkim, kad ant Mikrotiko pakurti AP su vlan-id 6, o prie priedėlio kalbeliu pajungti dar vieną AP tik kaip client pajingti prie Mikrotiko AP. Ar toks variantas veiktų? Ir tada ar ant Mikrotiko galima pakurti kelis AP, kad vienas būtų su vlanid 6, o kitas paprastas interneto.

    AtsakytiPanaikinti
    Atsakymai
    1. Pas mane buvo identiska situacija. Neveikia per wifi. Multicast neina, trukcioja. Bandziau eoip over wifi - geriau, bet vistiek sutrukcioja vaikstant po kambari, nes srautas UDP, jame nera flow-control.
      Nupirkau "Tenda gigabit powerline" adapterius is aliexpress ir per juos paleidau. Veikia puikiai. Tiesa reikia uztikrinti, kad ta pati faze (is trifazes) butu privesta prie adapteriu. Tuos adapterius galima sujungti netgi daugiau nei du i kruva.

      Panaikinti
    2. Ačiū. Atrodo daug žadančiai tie Tenda adapteriai.
      Dėl fazės, kaip įsitikinti, kad tai yra ta pati fazė? Ar tai reiškia, kad abi rozetės turi būti po tuo pačiu automatu?

      Panaikinti
    3. Sveiki,
      ką tik pajungiau per Tenda PH6 (AV1000). Patvirtinu, kad viskas veikia.

      Panaikinti